Skip to Content

半步中文体验包: (2011-05-27 v0.5.25)支持更多的Puppy版本

sasaqqdan 的头像
平均评分: 4.4 (594 次评分)
古有半步颠,现有半步包;
古有含笑半步颠,现有中文半步包;
古代明朝有含笑半步颠,现代天朝有中文半步包
古代明朝唐伯虎有天下第一奇毒含笑半步颠,…☭☭☭…卍卍卍…。

英文版puppy下半步中文体验包的下载安装流程请看这个贴子。主要功能请查看示意图
如果只需要支持i18n的jwm,请点击这里下载,安装并重启X后永中office等java程序的标题栏不再乱码。

Puppy的官方版本不少,派生版本更多。为方便大家体验尝试各种不同类型的Puppy新版本,特制作“半步中文体验包”(不是一步到位包,也不算中文支持包)。注意:迷你版只为老版本半步中文体验包升级方便用(直接覆盖安装),如果是第一次在系统上安装半步中文体验包,请下载安装完整版

版本说明:

2011-05-27,V0.5.25。更新说明:修复seamonkey1.1.x无法自动汉化错误。

菜单如图:

libreoffice3.3汉化包libreoffice3.3中文版(依赖于java)和Lighthouse Pup 5.02 G-Mariner的屏幕快照:


注意:sfs_linker挂载的sfs镜像文件必须放到指定的puppyoutplugins根目录下,才能在保存个人文件并重启后自动挂载使用。如图。)

半步中文体验包包括fcitx输入法sakura终端文泉驿点阵宋体、文泉驿微米黑矢量字体,内含麻花藤LinuxQQ的qqshell安装脚本

安装结束后请手动重启X-服务器,如果在安装软件后菜单或界面出现中英文混杂和中文乱码等问题,请在终端下运行半步包核心脚本:
puppy2barbie

设计目标:

重点支持Puppy4.3及以上官方标准版和Quirky,尽可能支持不同版本的外文puppy、puppies、nop、upup等,并智能汉化其中的常用软件。
想试用国外比较流行的Puppy发行版?可看看这个帖子


相关软件中附上专用于Puppy4.3x系列的icewm、支持hal的lxde、支持hal的xfce4桌面环境pet包(特别感谢withoutpity),请与半步中文体验包配合使用。

已知BUG:

该包不适用于Full Install(即完整安装到整个ext分区)的系统,在Full安装的系统如果已安装老版本的半步包,建议直接覆盖安装,不要卸载老版本。(Frugal安装的系统也可以直接覆盖安装,一般不影响使用。)

如果无线上网有问题,可试试jemimah的Frisbee Network Manager
安装顺序:(--lupu5.2的可跳过以下步骤直接安装Frisbee-beta-2-lucid52.pet--)
1.对应的wpa_supplicant pet (for lupu | for wary | for puppy4.2/4.3)
2.patched dhcpcd pet
3.xpupsay pet
4.Frisbee pet
5.重启电脑

相关软件中还有小小输入法SCIM中文输入平台,请配合0.2.1版以上的半步中文体验包使用。
简单介绍一下注销进入命令行界面后的操作命令,以方便刚入门的朋友:
poweroff 		#关机
reboot 			#重启
xwin			#进入图形界面
xwin jwm		#启动jwm桌面环境
xwin icewm-session	#启动icewm桌面环境
xwin startxfce4		#启动xfce桌面环境
xwin openbox		#启动lxde桌面环境
制作方法: 
半步中文体验包主要功能示意图:


2009-10-12:V0.0.1版,完成jwm/icewm/xfce4的中文菜单和桌面的中文化脚本,seamonkey汉化。
2009-10-14:V0.0.2版,升级修复jwm/icewm/xfce4的中文菜单和桌面的中文化脚本puppy2barbie。
2009-10-17:V0.0.3版,fcitx输入法升级到V3.6.2版本,并添加了仓颉输入法以方便海峡那边爱好Puppy的朋友;加入对firefox/1.5/2/3和opera9/10的智能汉化支持;添加了rox、pfind、xarchive、geany、abiword、 gnumeric等常用软件的汉化文件。
2009-10-18:V0.0.4版。主要是针对0.0.3版的bug修复,添加了pprocess、pppoe_gui、pppoe-setup、thunar、mousepad、pcmanfm的mo汉化文件。
2009-10-19:V0.0.5。更新说明:修正了petget使其只生成中文菜单,更新sakura为V2.3.2版,用支持中文显示与输入的urxvt替代rxvt,添加了pmount、pmusic、mtpaint、gpicview等mo中文文件。
2009-10-21:V0.0.6。更新说明:修复了firefox中文化脚本,更新了jwm/icewm/xfce4/LXDE的中文菜单和桌面的中文化脚本puppy2barbie。
2009-10-25:V0.0.7。更新说明:增加了rox右键打开方式功能,修订了以前版本的小bug。
2009-10-25晚:V0.0.8。更新说明:withoutpity制作的lxde桌面环境真不错,该版本针对lxde作了脚本优化。这是我以withoutpity制作的lxde桌面环境为基础做的lxde桌面pet包,大小为5.7MB。
2009-10-27:V0.0.9。更新说明:针对seamonkey书签、wine迅雷、lxde图标等问题作了些脚本修正,请在安装时关闭所有运行的程序,安装结束后会自动重启X-服务器。
2009-10-29: V0.1。更新说明:不说了。md5sum: 49f901391bb7d4720ed6437d09eeba98 cnpack_half-4xx-20091029.pet
2009-11-1:V0.1.1。更新说明:增加了对常用输入法如yong、fictx、scim的环境变量支持和各种不同桌面环境如jwm、icewm、lxde、xfce的启动脚本支持。
2009-11-2:V0.1.2。
2009-11-3:V0.2.0。更新说明:优化了菜单自动翻译脚本,在使用中文化后的seamonkey1.1.x时,如出现无法运行或出错,请运行脚本: puppy2seamonkey1x
2009-11-5:V0.2.1。更新说明:更新了对scim和scim-bridge输入法的支持,可在java程序中正常使用scim。
2009-11-7:V0.2.2。更新说明:增加了X桌面重要文件~/.xinitrc的备份功能,备份文件在/root下,文件名为:“.xinitrc.+当前时间”。将sakura重新设置为jwm和icewm桌面的默认终端,通过bootmanager调整sfs文件加载并重启后,自动清理桌面上多余的rxvt终端。
2009-11-12:V0.2.3。更新说明:修复了在jwm、icewm、lxde、xfce四种桌面之间进行切换时主菜单图标显示不全问题。
2009-11-12:V0.2.4-mini。更新说明:为节省上传时间和安装时间,从0.2.4版开始,一般情况下都以迷你版方式发布(只包含puppy2barbie等少量脚本,安装包大小只有0.02MB),未安装完整版中文体验包的朋友请先下载安装完整版的中文体验包。本版继续修复jwm、icewm、lxde、xfce四种桌面之间切换时主菜单图标显示不全问题。
2009-11-22:V0.3.0。更新说明:从0.25到0.3.0版,主要修复了一些中文化细节问题,内置脚本editinit2cn会自动寻找puppy安装目录并修复vfat分区无法显示中文问题;内置脚本puppy2cn2en可将已中文化的界面及菜单转成英文,以方便喜欢全英文界面的朋友;内置脚本puppy2nocnmenu可将/usr/share/desktop-directories和/usr/share/applications等目录中未能通过puppy2barbie汉化的菜单项找出来,并自动生成puppy2barbie可用的sed替换格式;内置脚本set-filemanager(菜单项:选择文件管理器类型)与rox相配合,可通过点击jwm/icewm桌面上“文件”或分区图标直接打开所选择的Thunarpcmanfm
2009-11-25:V0.3.3。更新说明:改正了seamonkey浏览器的中文化方法,在汉化过程中,请点击关闭自动打开的浏览器窗口,一般情况下要在关闭浏览器窗口两次后才完成seamonkey中文化。
2009-12-10:V0.3.9。更新说明:改进了seamonkey1.1.x的汉化脚本、hal支持、自动修复nop431等版本的modprobe nls_utf8错误......
2009-12-15:V0.3.12。更新说明:根据“无线电子”的建议,增加了安装汉化脚本puppy2barbie的重定向汉化功能,如运行:puppy2barbie -dir /mnt/sda7即可对完整安装在/mnt/sda7下的puppy系统进行中文化。
2009-12-19:V0.3.14。更新说明:汉化了桌面分区图标、回收站、网络连接等桌面图标的右键菜单,增加了qqshell脚本左手鼠标配置向导等。
2009-12-22:V0.3.16。更新说明:针对quirky的libc版本兼容等问题作了优化,添加了mtpaint3.31和rox2.9汉化文件。
2009-12-27:V0.3.18。更新说明:修正了非英文版puppy(如xp-like puplet)在汉化后键盘布局不适用等问题,附带升级pidgin到V2.6.4
2010-01-01,V0.3.21。更新说明:添加zigbert编写Puppy控制中心脚本pcc和ttf字体安装脚本pfont,点击桌面图标“设置”即可打开pcc。
2010-01-03,V0.3.22。更新说明:脚本细节问题改进,创建google的code项目,并上传最新版本。
2010-01-06,V0.3.24。更新说明:加入tasmod编写的启动时自动挂载分区脚本Startmount
2010-01-09,V0.3.26。更新说明:升级了tasmod编写的启动时自动挂载分区脚本Startmount,添加开关机声音脚本pstartupsound。
2010-01-11,V0.3.27。更新说明:pmount和fixmenus脚本兼容性修正。
2010-01-13,V0.3.29。更新说明:针对使用google chrome浏览器的browserlinuxwolfe-008作了脚本优化。
2010-01-15,V0.3.30。更新说明:升级startmount到0.1版,修复了自动挂载ntfs分区时中文无法显示和只读问题。
2010-01-17,V0.3.32。更新说明:增加了puppy stardust 005的中文化多重菜单,中文菜单示例
2010-01-21,V0.3.34。更新说明:修复了jwm主题切换后菜单和标题乱码。
2010-01-25,V0.4.00。更新说明:修复了fixmenus脚本错误,添加了firefox3.6的中文扩展,puppy stardust 006菜单汉化。
2010-02-01,V0.4.02。更新说明:添加了jwm的i18n国际化支持和中文支持,在jwm桌面环境下打开永中office标题栏不再乱码
2010-02-06,V0.4.03。更新说明:增加了对puppy stardust 008的支持。
2010-02-23,V0.4.07。更新说明:增加了对puppy stardust 011browserlinux新版的支持,修订了firefox汉化脚本;为减少半步包体积,点阵字体只保留wenquanyi_10pt.pcf。
2010-02-25,V0.4.08。更新说明:进一步精简半步包体积到10.5M,删除以下文件:/usr/share/i18n/locales/iso14651_t1_pinyin;/usr/local/barbiedata/usr_bin/geany;gimp20*.mo;libc.mo,替换字体文件wqy-microhei-lite.ttf为wqy-microhei.ttf,升级pcc,增加ntfs-backup。
2010-02-27,V0.4.09。更新说明:升级fcitx到V3.6.3,Startmount到V0.4.0,pet大小为10.6MB。
2010-02-28,V0.4.10。更新说明:用DroidSansFallback.ttf代替wqy-microhei.ttf,pet大小为9.7MB。
2010-03-01,V0.4.11。更新说明:由于DroidSansFallback在wine中测试乱码,字体返回wqy-microhei.ttf;增加对puppy stardust 012的支持;pet大小:10.5MB。
2010-03-03,V0.4.20。更新说明:继续精简pet,去除调试软件strace,用0.8.1嬴政版的wenquanyi_10pt.pcf代替最新的文泉驿点阵宋体,改进了mtpaint在不同puppy版本下的汉化方式,pet大小:9.9MB。
2010-03-04,V0.4.21。更新说明:增加了对quirky 008的支持,pet大小:9.9MB。
2010-03-05,V0.4.22。更新说明:增加了对Puppy 214X的支持,pet大小:9.9MB。(Puppy 214X 适合特别老旧的古董电脑)
2010-03-06,V0.4.23。更新说明:增加了完整汉化模式(中文显示和中文输入法支持,并对系统界面和菜单进行汉化)和最小汉化模式(仅提供中文显示和中文输入法支持,不汉化系统界面和菜单)(感谢老笨牛的建议)。
2010-03-07,V0.4.24。更新说明:修订了最小汉化模式,去除了对firefox1.x和2.x的汉化支持,pet大小为9.6MB。
2010-03-09,V0.4.25。更新说明:通过降低libvte9的版本,增加对Puppy3.x的支持,pet大小为9.6MB。
2010-03-12,V0.4.27。更新说明:修正不同puppy版本下abiword V2.4-2.8和mtpaint的支持,pet大小为9.6MB。
2010-03-16,V0.4.28。更新说明:修正fcitx-3.6.3配置文件错误和某些版本下jwm菜单乱码,pet大小为9.6MB。
2010-03-17,V0.4.29。更新说明:增加对Jkl9543制作的puppy432中文增强版的支持,pet大小为9.6MB。(特别感谢Jkl9543,如果想汉化puppy432中文增强版的菜单,可直接下载安装半步中文体验包迷你版)
2010-03-23,V0.4.30。更新说明:增加对电子书阅读工具FBReader的中文支持,pet大小为9.6MB。
2010-03-30,V0.4.33。更新说明:增加对Lucid Puppy的中文支持,pet大小为9.8MB。
2010-03-31,V0.4.34。更新说明:压缩ttf中文字体和fcitx词库,pet大小为9.0MB。
2010-04-02,V0.4.35。更新说明:增加对seamonkey2.0.x的汉化支持(前提是要先连接到互联网),pet大小为9.1MB。
2010-04-06,V0.4.37。更新说明:升级Startmount到V0.5.0,pet大小为9.1MB。
2010-04-12,V0.4.39。更新说明:增加对quirky 018的支持,pet大小为9.1MB。
2010-04-14,V0.4.40。更新说明:升级并修复Startmount V0.5.1的vfat分区挂载等脚本错误,pet大小为9.1MB。
2010-04-17,V0.4.41。更新说明:增加对Lucid Puppy 006的支持,jwm for i18n升级到vsvn-469,pet大小为9.1MB。
2010-04-23,V0.4.42。更新说明:fcitx降级到更稳定的V3.6.2,修复jwm for i18n对不同puppy版本的支持,pet大小为9.1MB。
2010-04-24,V0.4.43。更新说明:修复了puppy43X系列下gnumeric在单元格输入状态下回车后自动崩溃问题(感谢xbl提交的bugs),pet大小为9.1MB。
2010-05-16,V0.4.44。更新说明:增加了对puppy5.0和quirky1.1的支持,pet大小为9.1MB。
2010-05-19,V0.4.45。更新说明:修复v0.4.44的脚本中jwm相关bug和puppy5.0中的abiword中文脚本支持,增加了rox右键解压rar和deb到当前目录的脚本,pet大小为9.1MB。
2010-05-22,V0.4.46。更新说明:升级Startmount到V0.5.3,增加对Lighthouse Pup的支持,pet大小为9.1MB。
2010-05-23,V0.4.47。更新说明:修复并整合sfs_linker及系统外挂脚本ppplug,可在不重启puppy的情况下方便挂载使用dev_xxx.sfs等镜像文件。pet大小为9.5MB。
2010-05-29,V0.4.48。更新说明:修复lupu5对文泉驿pcf字体WenQuanYi Bitmap Song的支持。pet大小为9.5MB。
2010-05-31,V0.4.49。更新说明:增加deb2pet,汉化并升级lupu5的quickpet到V2.1.11。pet大小为9.5MB。
2010-06-04,V0.5.00。更新说明:修复汉化脚本,增加永中eio的中文乱码修复功能及jre自动配置,修复inkscapelite中文乱码,制作半步中文体验包主要功能示意图。pet大小为9.5MB。
2010-06-06,V0.5.01。更新说明:继续修复汉化脚本bugs,修复sfs_linker挂载问题,半步包主要功能请查看半步中文体验包主要功能示意图。pet大小为9.5MB。(注意:sfs_linker挂载的sfs镜像文件必须放到指定的puppyoutplugins根目录下,才能在系统重启后自动挂载使用。
2010-06-10,V0.5.02。更新说明:继续修复sfs_linker挂载问题,增加已汉化的grub4dosconfig(感谢日本朋友shinobar),pet大小为9.8MB。
2010-06-12,V0.5.03。更新说明:修复wary puppy的filemnt、sfs_linker挂载sfs4等问题,pet大小为9.8MB。
2010-06-15,V0.5.04。更新说明:修复最新版本VirtualBox的内核模块支持,pet大小为9.8MB。
2010-06-26,V0.5.05。更新说明:增加对spup020puppeee的支持,pet大小为9.8MB。
2010-06-30,V0.5.06。更新说明:修复puppy文件放在硬盘或U盘vfat分区根目录下时无法显示该分区下的中文文件名等问题,pet大小为9.7MB。
2010-07-10,V0.5.07。更新说明:修复fcitx无法激活等问题、升级pmusic、pprocess、quickpet中文语言文件,pet大小为9.7MB。
2010-07-20,V0.5.08。更新说明:修复对nop系列版本的支持,pet大小为9.7MB。
2010-07-24,V0.5.09。更新说明:修复某些版本下icewm的中文主菜单乱码及pmusic中文语言文件,pet大小为9.7MB。
2010-08-12,V0.5.10。更新说明:修复对Lucid Puppy 5.1的支持,quickpet升级到V3.0pre,pmusic升级到V1.1.1,pet大小为9.8MB。
2010-08-18,V0.5.11。更新说明:增加对Lighthouse Pup 5.00 D的支持,pet大小为9.8MB。附专用于Lighthouse Pup 5 的menu.lst格式:
title Lighthouse Linux 5.00 D (frugal on sda8)
kernel (hd0,7)/lhp500d/vmlinuz pmedia=atahd pdev1=sda8 psubdir=lhp500 xforcevesa nomodeset
initrd (hd0,7)/lhp500d/initrd.gz
2010-10-10,V0.5.12。更新说明:针对wary puppy 的bug修复。
2011-01-01,V0.5.13。更新说明:针对新版wary puppy和lucid puppy的bug修复,更新quickpet、grub4dosconfig等。
2011-01-01晚,V0.5.14。更新说明:主要是针对V0.5.13版的bug修复。
2011-01-11,V0.5.15。更新说明:针对LupQ的bug修复。
2011-01-12,V0.5.16。更新说明:针对lupu5.2的vfat分区中文乱码修复。
2011-01-16,V0.5.17。更新说明:主要是针对 LightHouse pup 5.00G 的bug修复。
2011-01-18,V0.5.18。更新说明:继续修复 LightHouse pup 5.00G 的bug,将Seamonkey 1.x的汉化转为网络更新。
2011-01-19,V0.5.19。更新说明:主要是修复 针对Lighthouse Pup 5.02 G 的bug,制作libreoffice3.3汉化包
2011-01-22,V0.5.20。更新说明:因Seamonkey和Firefox的版本多,将semonkey和firefox的汉化包全部转为网络下载,包大小现为9.0MB。
2011-03-03,V0.5.21。更新说明:针对Wary 5.1/5.1.1的bug修复。
2011-03-12,V0.5.22。更新说明:添加了网络连接语言环境选择向导,连网时可手动选择locale
2011-03-25,V0.5.23。更新说明:更新fcitx到v4.0.1,添加fcitx-wb98、flashplayer plugins、firefox中文版网络自动下载安装脚本(菜单位置在 菜单|实用工具 下,以BarbieTool开头)
2011-04-02,V0.5.24。更新说明:修复通过菜单自动下载安装firefox中文版错误。
2011-05-27,V0.5.25。更新说明:修复seamonkey1.1.x无法自动汉化错误。
#5967
说得好,免得一些家伙挑骨头。
#5971
其实挑骨头是好处的,没人挑骨头就不会改进!!!
#5972
不常用得东东根本不需要汉化。
#5976
http://puppyisos.org/isos/2009-01-to-06/puppy-413NOP-de.iso

NAME: puppy PASSWORD: linux

Extra drivers for Puppy 4.1 with 2.6.25.16 kernel (英文论坛)

http://www.murga-linux.com/puppy/viewtopic.php?t=42497


网站上看到不少朋友喜欢NOP圣诞版,我是其中之一,这个版本更新了不少软件,昨天麻烦无线电子,他一时太忙,没搞出来!!!如果版主有时间的话,就改改这个版本吧!!2008.12.24 发布“圣诞版”,到现在NOP版好长时间没更新了,谢谢你的无私奉献精神!!!!!
#6004
版主,为什么我现在用pup2usb安装任何版本的puppy到U盘,启动时都启不来,每次的安装过程都显示成功,就是U盘启动时起不来,可是以前能起来的,U盘还是原来的2G U盘,怎么也弄不成功。换其他的优盘也不行,不知道怎么回事。不过安装到硬盘的没问题可以起来。希望斑竹帮我找一下问题所在,不甚感激!
#6005
请检查 USB 接触是否良好,BIOS设置USB接口启用了没有
#6006
请检查 USB 接触是否良好,BIOS设置USB接口启用了没有
#6007
您好,USB接触应该没问题,而且我在笔记本和台式机上都试了,BIOS 也设置USB启动了,操作系统是深度精简版的Deepin6.2的XP
#6008
还有该优盘制作的winpe就可以U盘启动,可以排除以上2种可能,谢谢老谢,不过请问还有其它的可能导致了U盘puppy启动不起来吗?
#6009
USB无法启动PUPPY ,这种情况我也碰到过,不知故障原因是否一样。但我用 Usboot170.exe将U盘格式化为 USB-ZIP模式。
再用pup2usb 安装ISO,安装过程中最好使用完全格式化,还有BIOS的 第一启动模式也改成 USB-ZIP

如果不行就换 USB-HDD 或 USB-FDD ,切记U盘的模式一定要要BIOS设置的启动模式
不能确保成功,试试看吧!
#6010
切记U盘的模式一定要与 BIOS设置的启动模式一致
#6011
还是老谢热心啊,谢谢了,我再试试
#6013
打过initrd补丁吗?我想用dev包
#6060
4.3已经正式发布了,官网下载
#6062
initrd.gz怎么用
#6069
等半步中文体验包下载地址
#6079
5
聊天软件不用EVA?
#6388
搞什么啊,我只要对中文支持的包:中文字体+输入法别的不要。
#6417
我也是一样。
#6389
使用英文版最好,无需什么包。
#6390
puppylinux对中文支持以后才可以上中国的网站,要不把它就没什么意义。
#6391
带来完美体验的中文支持和稳定可靠的常用软件集成都是必需的,驱动也要更新以尽可能的发挥硬件的性能,这应该是中文化PUPPY的宗旨
#6418
苍天啊 大地啊 是哪位神仙姐姐做的大功德啊
#6420
是那個儍儍QQ神仙姐姐
#6429
有没有好的播放器啊?
#6432
播放器Puppy自带了好多呢。
希望版主快些出一步包啊,眼睛都蓝了
#6442
请问:
怎么打开原有的中文文档时,无法显示中文,改字体都不行
但是新输入的中文字体可以正常显示,
怎么解决,
谢谢!
#6444
原版puppy 4.3.1使用V0.0.2版能够正常实现中文化,安装之后菜单仍然是英文,重启之后则全部中文化了。在安装gmlive的过程中同样遇到菜单变英文-重启之后恢复中文的情况。总之还是很符合我的要求,能够显示和输入中文就ok了,不需要太多汉化。
#6445
原版puppy 4.3.1使用V0.0.2版能够正常实现中文化,安装之后菜单仍然是英文,重启之后则全部中文化了。在安装gmlive的过程中同样遇到菜单变英文-重启之后恢复中文的情况。总之还是很符合我的要求,能够显示和输入中文就ok了,不需要太多汉化。楼主辛苦拉
#6447
真的好用 我下的Macpup412.iso都能正常汉化菜单 楼主辛苦啦
#6452
5
版主做了非常好的工作!
会在Puppy推广上立下新的里程碑!
#6461
官方更新到4.3.1了,这个中文包是不是也要更新啊?
#6486
昨天晚上才下的4.31和0.04体验包安装的,现在来看又有更好的0.05体验包了,晕!
#6502
更新很快哦,支持!
#6521
#6523
能否发一个仅支持中文字体+输入法,不需要汉化
#6552
5
想仅支持中文字体+输入法,不需要汉化?
你下载本站的fcitx就是输入法,至于中文字体随便找一个WIN下的中文字体CP到/usr/share/fonts目录,命令行中输入fc-cache就可以
自己动手,丰衣足食
#6568
不知楼主所做的 LXDE 桌面包是指整个 LXDE 环境,还是指在那个桌面环境上适用的一些桌面软件包?
#6585
sasaqqdan 的头像
lxde pet包是lxde桌面环境,可与中文体验包一起配合使用
#6601
我现在用的是官方的4.31,这个半步包的0.1还不敢用,因为之前有试过0.06,0.07,0.08,0.09的都出现了各种各样的问题,而且一个通病是安装了中文包以后会导致无线网卡搜索路由器失败。不知道作者在0.1版中是否有改进。我现在用的0.06版,因为它问题比较少。而且无线网卡的问题也可以通过手工解决。
#6603
sasaqqdan 的头像
Re:#6601

不知道你所说的是不是“网络配置向导”中的问题,由于我没有这种类型的无线网卡,没法测试,你可以下载0.1版测试一下,有问题的话,请在终端下运行:
bash -x net-setup.sh
和
LANG=en_US && net-setup.sh
把终端里面显示的调试信息发上来看看。
#6613
puppy-4.3.1安装这个半步包的0.1重新定制puppy不能生成正常的iso文件,因为显示只有12M,不应该这么小呀!
#6671
我的电脑显卡是Intel GMA950,想用Puppy却不能使用,是不是驱动的问题啊?(这台电脑用的是古董NVIDIA GeForce 256.
#6676
sasaqqdan 的头像
先选择xvesa,再用puppy软件包管理器下载安装xorg_xorg_dri-7.3-1
再选择xorg试试
#6677
newyearspup那个界面能不能做个单独的PET?
#6683
支持中文包越做越完善。
#6692
5
版主,我对你修正后的Lxde桌面环境做了一些美化,包大小是6.4MB,在这里下载,不过这个包有这么几个问题:
1、安装前如果已经安装过以前的Lxde桌面环境,需要删除/usr/lib/lxpanel下的文件,安装后想运行
/etc/rc.d/rc.hald restart
这两个脚本我不会写;
2、我在/root/.gtcrc2.0-mine中指定了Panel菜单的大小,可是只有nimbus主题才能显示正确的图标大小,为什么呢?难道是主题里指定的要比/root/.gtkrc2.0指定的要优先吗?
3、我修改了一下/root/.xinitrc判断Openbox窗口管理器的脚本,如果不修改的话是否可以也正常执行?原来的那个包好像不执行Pcmanfm?
这个包做的修正有:
1、去除了Lxpanel出错的插件,现在可以自由添加删除Panel上的插件而不出错了;
2、增加了两套图标,三套主题,图标分别是Humanity、Drakfire Evolution中的Light_Icons,主题分别是Doka、Moomex-Ultimatum、nimbus,均取自www.gnome-look.org,感谢它们的作者,原下载链接分别是
图标Humanity:
http://www.gnome-look.org/content/show.php/Humanity?content=111517
图标Light_Icons:
http://www.gnome-look.org/content/show.php/Drakfire+Evolution+%28white-black+tray%29?content=104614
主题的地址就不一一列出了,一搜索都有的;
3、在Lxpanel的菜单里增加了注销、重起和关机,不过不知道怎么才能加上一个确定步骤呢?现在一点要直接执行了;
4、默认两个Panel一上一下,都含有任务面板。
现在安装完后的界面(Humanity+Moomex-Ultimatum):

可以自由增删插件了

望版主帮俺修正!
#6693
sasaqqdan 的头像
做得不错,关于你说的几个小问题:
一、删除/usr/lib/lxpanel下的旧文件,先安装pet包再运行:
find /usr/lib/lxpanel -cmin +5 -type f -delete
就可以把5分钟内的未得到修改的文件删除。
二、/usr/lib下的*.la或*.a一般只在编译时才有用,可以删除:
find /usr/lib -name *.la -delete
find /usr/lib -name *.a -delete
三、运行/etc/rc.d/rc.hald start的脚本在/etc/rc.d/rc.sysinit里面了。安装后最好重启一下,可以避免许多问题。一定要用的话,可以添加脚本文件到/root/Startup下。
四、Pcmanfm的运行脚本已包含在最新的中文体验包中了。
五、/usr/share/themes/dark-nimbus/gtk-2.0下面的链接文件有错误,可能是用pcmanfm复制引起的,如果要复制包含链接文件的目录,最好通过命令行或rox。
六、lxde我很少用,图标和菜单问题我解决不了,辛苦了。
#6695
谢谢版主解答,可是我选择xvesa后,显示器上却显示“超出范围”,我该如何是好啊?谢谢了。(还是Intel GMA950那个)
#6696
sasaqqdan 的头像
这是我的一台电脑上的显示设备,用puppy完全正常(用everest检测):
显示卡 Intel(R) 82945G Express Chipset Family (96 MB)
3D 加速器 Intel GMA 950
显示器 即插即用监视器 [NoDB] (0194870124903)
显示器 即插即用监视器 [NoDB] (0194870124903)
#6697
5
find /usr/lib/lxpanel -cmin +5 -type f -delete
这个是要写到Openbox-pcmanfm目录里的pinstall脚本里吗?
#6698
sasaqqdan 的头像
恩,考虑到pet安装时的文件复制时间,可以用:
sleep 5 && find /usr/lib/lxpanel -cmin +5 -type f -delete
#6699
我试过了,Thunar不会复制出错,哎,还是用Xfce吧,告别Lxde了,怪不得洪哥要重写Pcmanfm的代码呢。
<!--break-->
还有一个问题,就是pcmanfm复制连接的时候会出问题,那么Thunar呢?Rox是肯定不会了,可是我想要是装上XFCE4用它的时候就不多了
#6788
http://puppylinux.asia/tpp/NOP/


USER: puppy
PASSWOERD: linux


puppy-431-NOP-r1.iso这个版本。用不了本站做的输入法,小企鹅输入法和SCIM中文输入平台都用不了,SCIM输入法界面竟然是英文的,我已经将系统语言调成 zh_CN-UTF8
#6789
sasaqqdan 的头像
要在安装中文体验包后,才能再安装试用其他的输入法。
#6938
备忘:scim安装和使用
安装半步中文包中的scim
安装scim-pinyin-0.5.91-i486.pet
安装scim-anthy-1.2.6-i486.pet
安装anthy-9100h-i486.pet
修改/root/.xinitrc
注解掉fcitx相关
修改后.xinitrc
## insert by chinese_pack_total-4.1.0.10 ##
locale | grep "LC_CTYPE=\"\?zh_CN\." || export LC_CTYPE="zh_CN.UTF-8"
export GTK_IM_MODULE="scim-bridge"
export QT_IM_MODULES="scim-bridge"
#export XMODIFIERS="@im=fcitx"
#export GTK_XIM_MODULES="fcitx"
#export QT_XIM_MODULES="fcitx"
#config creation bug-fix for fcitx
#if [ ! -e /root/.fcitx/config ] || [ "`md5sum /root/.fcitx/config`" = "eb8edb73159e0a6b228de1af183b87c9 /root/.fcitx/config" ]; then
#cp /usr/share/fcitx/data/config /root/.fcitx/config
#fi
#fcitx &
##########

export QT_IM_MODULES="scim-bridge" 解决opera等qt程序下输入
重启x
#6939
放狗搜了一下无法解决中文pinyin状态下默认标点为半角的问题
希望得到帮助
#6953
汉化不了Macpup Opera版的puppy,非常喜欢用Macpup Opera版。外观做得非常漂亮。
但是最新版Macpup Foxy 3又可以汉化不知道为什么。
#6954
sasaqqdan 的头像
经测试,最新版本的macpup可以汉化,但打开opera时菜单显示乱码,通过首选项|高级|字体|浏览器菜单|WenQunaYI Bitmap Song即可显示中文。
附macpup opera桌面截图
由于半步包在设计时未考虑enlightenment桌面环境,可能在使用中还有其他问题,请爱好macpup或精通enlightenment的朋友及时反馈。
#7157
自动挂载分区默认无法显示NTFS中文目录

需要手动修改/etc/fstab
在每个盘符后面添加 nls=utf8 0 0才正常

如:/dev/sda5 /mnt/sda5 auto nls=utf8 0 0

望修正
#7158
又发现一个BUG,这样启动了之后会发现权限不够无法启动部分脚本
#7159
NTFS自动挂载之后权限不够的原因我终于找到了……

附上解决办法

修改/root/startup/start-mount.sh
全部改成这种格式
mount -t ntfs-3g /dev/sda5 /mnt/sda5
(如果是fat格式的分区请把ntfs-3g改成vfat即可)

配合上我前面发的中文目录修改,这下终于可以完美自动挂载分区了
#7165
sasaqqdan 的头像
谢谢,已根据你的意见和方法升级了半步包。
#7168
我今天发现就算这样还是搞不定只读问题,手动启动那脚本就不会只读。如果是自动启动就会……很莫名原因未知………………

顺便问下版版,知不知道怎么解决puppy下无法被连接的问题?

比如我魔兽建了个服务器,别人能看到就是进不去
而我可以进别人windows的服务器
如果两台都是PUPPY那就会很悲剧的互相能看到,但是谁都进不了谁的房间……
#7169
而且,我也没有安装任何的防火墙软件……奇怪了
#6967
最新版本的macpup应该是Macpup Foxy 3,用半步中文包后汉化非常完美,不过很多方面没有Macpup Opera这个版做的好,Macpup Opera用12.15中文包汉化不了,不过昨天用12.19这个中文包可以汉化,汉化效果也是相当不错。非常谢谢美女斑竹!
#6968
很好的系统,很好的网站, 很好的版主.
#7025
Quirky 0.0.2 使用最新版的半步之后无法重启
#7038
4
我超喜欢用macpup,它的界面很美观的。希望斑竹考虑下macpup,做下完美一点的macpup中文包。
#7098
好!
很好!
非常好!
楼主这贴来得太及时了,
正到处找呢!
强烈支持!
#7176
楼主,从你下的xfce4 HAL硬盘显示在media下,请问我要把它改到mnt下面可以吗
#7177
如果可以,要在那里改
#7178
5
可以改,但要手工修改/etc/fstab文件。
EXT*
dev/hda1 /mnt/hda1 auto noauto,rw 0 0
NTFS
dev/hda1 /mnt/hda1 auto noauto,defaults,iocharset=utf8,umask=000,nls=utf8 0 0
FAT
/dev/hda1 /mnt/hda1 auto noauto,defaults,iocharset=utf8 0 0
#7179
美女版主,我下载了pup460的那个版本,用了你的中文汉化包,无法更换主题,更换后菜单为方块,咋办???
#7180
sasaqqdan 的头像
感谢你的反馈,已修复,请下载最新版
#7181
sasaqqdan,还有一个问题,就是fcitx,在最新的quirky中如果退回命令行再进xwin的话,会再运行一个fcitx进程,切几回会占用大量CPU,再进xwin基本赶上死机了。
#7187
sasaqqdan 的头像
运行脚本:
sed -i 's@fcitx &$@killall fcitx; fcitx \&  #fix fcitx boot repeat@'   /root/.xinitrc
再重启X服务器即可
#7183
那个大虾指点一下 我下载了4.31我想在英文环境下面正确显示和输入中文

需要怎么设置啊

谢谢!~!~!~
#7185
装上中文的用无线网络向导就扫描不到无线路由器了,英文的可以,但英文的显示不了中文字。
#7189
sasaqqdan 的头像
我的电脑能扫描到无线,但无法自动设置路由:
#7190
我用Pwireless能扫描到无线,连接上后dhcp返回的地址是169.x.x.x这种地址,并且屏幕右下角没有连接图标。
#7195
我用的是MACPUP,装了googlechrome和中文包之后系统就出现问题了。很多程序无法启动。
#7199
版主好,我用的是Quirky0.05,我发现用它根本无法上网啊!我输入的都是对的,也成功连接上了,可是什么网页都浏览不了啊!连QQ也下载不了啊!下载时显示为:Temperary failure in name resolution.在那个PPPOE设置DNS,我输入“server”后,下面显示为:grep:/etc/recdv.conf: Too many levels of symbolic links /usr/sbin/pppoe-setup:line 156:/etc/recdv.conf: Too many levels of symbolic links,但脚本仍能正常运行,这是怎么回事啊?谢谢版主了!(我没用防火墙,是哈尔滨铁通的)
#7200
版主啊,麻烦您能不能单组做一个Quirky的半步中文体验包啊?我打开浏览器,看得全都是Puppy的介绍啊!要是太麻烦,做一个单独的Quirky说明文档用pet包压缩起来安上也行啊!一步到位中文包什么时候出来啊!谢谢了。
#7208
上面的Thunar文件管理器安装后geany文本编辑器无法运行,是什么原因?
#7212
奇怪了,版主睡觉了?
#7223
楼主提供的 <xfce4_hal桌面(专用于puppy4.3x系列-4.9MB-推荐★)>

安装完之后,1,xfce鼠标主题无法设置,
2无法挂载光驱,显示如图
#7224
5
mkdir /mnt/sr0应该可以解决光驱问题。
至于主题,是由于GTK+enegines与你现在用的主题不一致造成的吧,或者是你没有安装clearlooks的主题引擎。
#7230
美女版主:
用了汉化包之后,防火墙无法启动了,老是显示配置中断,然后就退出了。
#7455
谢谢美女。特别是感谢那个JWM下的I18N包。
报告两个测试结果:1、原半步包我下的是最新的版的,那个FCITX输入法无法更改自定义打开关闭输入法的快捷键。缺省的是CTRL_SPACE,我一般喜欢改成CTRL_LSHIFT,以前的可以改,但这个最新无法改,改了也不起作用。2、JWM下的I18N包,我是在PUPPY412下使用的,标题栏的乱码问题确实解决了,但JWM的样式变成了PUPPY431的样式。虽然不影响使用,但我一直非常喜欢412的样式风格。呵呵~~
#7468
还发现一个问题,不知道是永中OFFICE还是FCITX的问题:永中OFFICE中,有时候FCITX突然失灵了,尽管输入法已经正确切换,但就是输入不了任何文字,必须关闭和重新打开永中OFFICE才有可能输入(注意:是有可能,这个方法一般情况是管用的,但有几次也不管用,迫使我重启X)。
--老笨牛。
#7469
sasaqqdan 的头像
谢谢反馈,经试验,fcitx-3.6.3的配置文件位置已放到${HOME}/.config/fcitx/config,这个bug将在下一个版本半步包中更正。
#7474
viewnior.mo、burniso2cd.mo、leafpad.mo增加界面的几个英文翻译、ROX-Filer.mo增加右键菜单Open With...的翻译、pfilesearch添加search按钮的翻译、pburn、pbackup、pcd的语言文件翻译,目录右键菜单 search with pfind的翻译

就是不知道那些OK、YES等的按钮,文本编辑中右键菜单的COPY等在何处翻译
#11879
这些个翻译在哪里能找到?
#7475
Some time before, I really needed to buy a car for my firm but I did not have enough cash and could not buy something. Thank heaven my colleague adviced to try to get the <a href="http://lowest-rate-loans.com">loans</a> from creditors. So, I did so and was satisfied with my commercial loan.
#7559
5
谢谢你的更新! 我是puppy linux的新手 但是现在已经能开始享受使用了 谢谢!
#7597
5
感谢楼主的辛勤工作,中文半步包的最小汉化挺好的,但安装的输入法是小企鹅,不知道怎么输入日文呢?

我自己在scim-im上下载了scim,scim-pinyin,scim-anthy,anthy四个gz包,都编译安装成功了,但死活调不出任何输入法。

楼主对此有何建议?

ps:我用universal install安装到U盘上的,pup431
#7642
90561390
这是我建的puppy的QQ群,这样大家可以随时交流,欢迎大家加入。
#7643
90561390
这是我建的puppy群,这样大家可以随时交流,欢迎大家加入。
#7658
quirky018运行得非常非常稳定,而且这将是老教授钟意的未来的puppy5.0的雏形。希望能尽早看到这个版本的汉化包,呵呵。sasaqqdan美女又将忙活一阵子了。
#7677
谢谢sasaqqdan的最新中文支持包。我准备在quirky018上进行测试。回头把测试结果在这里贴出。--老笨牛
#7678
非常漂亮,非常棒!
不过,有一个很重要的问题,这个问题我也在官网提交过,就是 seamonkey无法访问任何中文网站,当然这肯定不是中文字体的原因。现在这个问题不存在了,但,用了这个中文包后,几乎我访问过的中文网站都存在乱码的问题,类似于�ҍ�ҍ��˘这种符号。
#7679
出现的两个网络连接的图标,但指向的都是同一块网卡。似乎一个是018的,一个是421的。
另外,seamonkey2.0.4应该对网页进行了严格的检验。现在许多中文网站浏览都不大正常。
--老笨牛
#7703
我今天用这个最新的包在puppy412下安装,发现永中OFFICE的标题栏依然乱码。单独运行那个国际化的I18N包之后,标题栏正常。--老笨牛
#7731
BUGS:20100414的那个包安装在puppy412下,原先通过gimp-2.6.3-cn-i486.pet安装并可正常使用的GIMP程序,当我选择chooselocale为zh_CN.utf8后,该程序无法运行,程序在进入主窗口的时候自动消失。--老笨牛
#7734
Segmentation fault(分割故障),在终端下运行gimp,出现这个故障。--老笨牛
#7752
可能是半步包的原因。我使用chinese_pack-4.1.0.8.pet就没这个问题,使用半步包最小汉化,产生了这个问题。--老笨牛
#7732
BUGS:20100414的那个包安装在puppy412下,所含sakura(48kb)通过ssh方式登录主机后程序自己消失,而用别的终端却没有任何问题。当我使用以前41kb大小的sakura登录,则完全正常。--老笨牛
#7738
sasaqqdan 的头像
谢谢你提交的bugs,原因正在查找中......
#7797
什么时间提供对wary020支持?
#7820
无线网络无法正常使用,虽然可以搜索与连接,但使用固定的IP地址与网关的时候,提示路由错误。试了多种方法也不行。chinese_pack-4.1.0.8.pet就没这个问题。----老笨牛
#7822
sasaqqdan 的头像
re:无线网络无法正常使用,虽然可以搜索与连接,但使用固定的IP地址与网关的时候,提示路由错误。

可试试在命令行下设置为英文语言环境变量后再运行脚本,如:
LANG=en_US  net-setup.sh
LANG=en_US  Pwireless
LANG=en_US  Pwireless2
LANG=en_US  connectwizard
LANG=en_US  /usr/local/net_setup/usr/sbin/net-setup.sh
#7825
目前看,还是chinese_pack-4.1.0.8.pet最稳定,最新的半步包,容易出现无法复制粘贴甚至输入的问题。我还是改回使用chinese_pack-4.1.0.8.pet包。---老笨牛
#7872
使用最新的半步包,安装在puppy412上。使用linuxQQ,当拖动一个窗口的标签时(比如我同时打开好几个群或者好友的对话窗口,QQ会自动排列这些窗口),只要稍微有拖动标签的动作,linuxQQ便不经任何提示便突然消失。需要重新打开程序才能正常运行。每次都是这样。--老笨牛
#7874
puppy412有一步到位包
#7890
想请教下,Puppy的新版本Lupu和Qkly有啥不同啊。。。从iso看,只是前者略大一点。
#7892
新半步包与quirky110配合得非常好,几乎没什么问题,也非常稳定。如果再出一个新的virtualbox就完美了。--老笨牛
#7901
字处理abiword菜单本来默认是中文,但是执行后反变成en_US, 仿照一网文,
http://www.runasimipi.org/blanco-en.php?file=abiword
要这样
LANG="zh_CN.UTF-8"
export LANG
abiword &
LANG="zh_CN.UTF-8"
export LANG
才能变回中文菜单。
#7902
在lupu上安装了半步包,中文显示很正常,但是输入法不好用,无法调出中文输入。不知道怎么回事?
#7913
puppy5.0使用半步中文体验包后,可以正常显示中文和生成中文名称的文件。
但是,以前生成的中文名称的文件及内容为中文的文件均显示为乱码,invalid encoding,
怎么解决这个问题?
谢谢!
#7934
quirky1.1加最新半步包,pzchmview无法打开CHM文件。--老笨牛
#7935
sasaqqdan 的头像
pzchmview可以打开CHM文件,喏:
#7938
是不是CHM文件有问题。同样的CHM文件,412下的那个软件可以打开,但quirky1.1却打不开,真是奇怪。--老笨牛
#7939
有些能打开,有些打不开,有些打开了但似乎显示有问题。另外,quirky1.1打开CHM文件默认的是chmseeshell,而这个命令或者文件并不存在。我自己把它改成由pzchmview命令打开。--老笨牛
#7936
puppy linux 5.0即lupu-500,里面自带的浏览器没有设置代理的地方?如何设置?如何设置全局代理?我要安装软件不能直接通过软件管理器来安装,必须先下载,原因是管理器也没地方设置代理。
#7937
sasaqqdan 的头像
#7955
http://github.com/adam8157/scripts/blob/master/extract

上面这个是我用于rox的脚本, 你可以改改用在puppy里, 主要是解决遇到有密码的包却无法输入密码导致x死锁, 开了个终端来解压. 支持多个同时解压, 按文件名建立文件夹等等, 我直接用了7z, 你可以单独设置, 例如deb用ar x...
#7966
输入法里能不能设置隐藏仓颉输入法?我只用五笔字型,经常在中英文切换的时候出现仓颉输入,在设置文件里也找不到如何设置。--老笨牛
#7967
sasaqqdan 的头像
geany /usr/share/fcitx/data/tables.conf
#7970
好了,谢谢。这下方便多了。--老笨牛
#7999
windows生成的中文文件名和内容都是GBK编码,在PUPPY里面均显示为乱码
怎么解决
谢谢
#8008
InkscapeLite矢量画图工具,打出来的汉字都是方框。--老笨牛
#8009
sasaqqdan 的头像
crtl+shift+t,选择中文字体。
#8012
嗯,我的意思是,选择字体工具进行文字输入的时候,缺省的能否就是汉字?--老笨牛
#8046
在用5.01,很好用!
另外,时评也很好:)
#8047
puppy 431 wine 100515 jwmrc-theme Wenquanyi Bitmap Song-12 改为 文泉驿微米黑 -16 重起jwm 更改成功.
重启X 又回到 Wenquanyi Bitmap Song-12 不知道什么原因,请版主指导.
#8048
谁能给我一个解释,我的天啊!
我的机子IBMR51,显卡为主板集成855GM,无论用Lupu5.01还是Quriky1.2,都是黑屏。只能用vesa驱动,那个显示效果差啊无法说了。用PUP431没问题的。何解?
#8051
永中office 中的方块字怎么解决。puppy 431
#8137
5
哈哈,感觉半步中文包很好用,顶顶~
试了好几个版本,包括Spup和Quirky1.20,目前最符合我个人要求的就是半步包+Quirky1.10了——上网(windows下时我还是比较喜欢1.x的海猴),word,pdf,看电影,没有IM需求,没有游戏需求。
自己不会只好稍微麻烦点了,不Save,关机速度也就可以接受了。很喜欢
圣诞版做替补,因为我的这个组合还是没有字幕呀==|||
完全没什么概念都不知道怎么设置,才入linux的门没几天的轻度使用者。
#8149
请教版主如何编辑rc.shutdown默认关机不保存.
#8189
5
发现这个半步中文包真的是弄的越来越红火~~
#8190
5
i see now, it's supported!
真是太棒了~
#8222
最新的iptux,谁能制作一个PET包?地址http://ppa.launchpad.net/lidaobing/ubuntu/pool/main/i/iptux/iptux_0.4.5.orig.tar.gz
#8255
我在X离子版(NOP431)安装07-20的迷你版之后,界面全部变成英文?求解
#8332
24版 5.01乱码啊
#8335
新的半步体验包在opera10.6下打词语的时候只能出现第一个字。不知道有没有人碰到过这个情况
#8338
sasaqqdan 的头像
这是opera10.60在linux下的bug,与半步包无关。
opera10.11及更早版本没这个问题。
#8343
哦,谢谢,期待早点出补丁或者解决方案
#8368
photor 的头像
要在老版本的半步中文体验包基础上升级,是要先卸载原来的版本还是直接覆盖安装?
#8443

发表新评论

 
  • 你可以在文本中使用BBCode标记语言。 URL会自动被转为链接。

更多关於格式化选项的信息